The Stovebolt Page Forums Home | FAQ | Forum | Swap Meet | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
Work those trucks!




Share what you're up to this summer!

Stovebolt Site Search
 
Old Truck Calendars
Months of truck photos!
Nothing like an old truck calendar

Stovebolt Calendars

Check for details!


Who's Online Now
7 registered members (Ghost_Rider, elm (51 Basket case), J Lucas, bolter5410, Eckroll, 1 invisible), 344 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums48
Topics116,486
Posts926,630
Members42,449
Most Online940
Apr 5th, 2017
Image Posting Policy
Previous Thread
Next Thread
Print Thread
Battery Not holding a charge 2 #90923 Tue Nov 09 2004 05:08 AM
Joined: Mar 2004
Posts: 58
D
dano69c10 Offline OP
Member
My 79 Chevy C30 has a new battery, new battery cables, new alternator, new belt, and the battery won't hold a charge. In the wiring diagram I noticed a green wire from the alt directly to the battery. Is this wire responsible for charging the battery, or is it the red or black wire that runs from the connector on the alt?
I thought that the red wire went to the ignition switch and the black wire went to the charge indicator.
If it is the green wire that's bad, can I run a wire directly to the positive terminal of the battery? I really can't see where the existing green wire goes to.


69 C10 LWB 250 L-6/3spd
79 C30 Crew Cab Dually 454 V-8/TH-400

"Takes more than a coat of paint to make it at Thunder Road!"
Re: Battery Not holding a charge 2 #90924 Tue Nov 09 2004 07:30 AM
Joined: Feb 2001
Posts: 80
O
Oehm Jr.'s 46 Offline
Wrench Fetcher
http://www.off-road.com/chevy/tech/grill/diagram.jpg

You might want to check out this wiring diagram. It shows a diesel engine, but my 76 Chevy has the same wiring with a heavy gauge dark green wire going to the horn, and a smaller gauge to the A/C pressure switch. There is no green wire coming off the alternator, just two reds and a brown.

Re: Battery Not holding a charge 2 #90925 Tue Nov 09 2004 07:30 PM
Joined: Sep 2004
Posts: 235
B
Big T Offline
Shop Shark
First of all, is the alternater charging 14 volts? Also you might have something draining the battery. If you have a volt meter, take the ground wire off the battery, take one lead from the meter and hook it to the battery and the other to the cable. ( you might have to switch wires on the meter) If it reads 12 volt, there is somthing draining the battery. With the meter hooked up, take the power wire off the alternater, if it goes to zero, you have a bad alternater. If you take the wire off the alternater and it is still 12 volts, start taking fuses out one at a time to find what is drawing power.normally the alternater will draw around five vols, thats fine

Re: Battery Not holding a charge 2 #90926 Tue Nov 09 2004 10:07 PM
Joined: Feb 2004
Posts: 19,025
H
Hotrod Lincoln Offline
Boltergeist
Disconnect one of the battery cables, and see if you get a spark when you touch the cable back to the battery post. If so, there's a constant drain that's responsible for the battery failing. If not, the alternator might not be charging. Check the voltage at the battery with the engine stopped. It should be about 12.5 volts with a well-charged battery. Running voltage at the battery, also with a full-charged battery, should be between 13.5 and 14.5 volts. When the alternator is recharging a low battery, the voltage might drop as low as 13, but the charging current will be high, 60 amps or more. As the battery recharges, the amp rate will drop, and the voltage will increase. A good-condition, well-charged battery should drop the amp rate to 10 or less, and the voltage should go well above 14 volts. Do you have an internally-regulated alternator, or is there a voltage regulator somewhere in the circuit? The wiring will be very different, depending on what type of alternator you've got.
Jerry


The murder victim was drowned in a bathtub full of Rice Krispies and milk.
The coroner blamed the crime on a cereal killer!

Cringe and wail in fear, Eloi- - - - -we Morlocks are on the hunt!
Re: Battery Not holding a charge 2 #90927 Fri Nov 12 2004 03:56 PM
Joined: Mar 2004
Posts: 58
D
dano69c10 Offline OP
Member
OK, I'm ready to lose it! I hate electrical problems!

While driving, my dash gauge is reading <8. The alternator is an internally regulated unit. While doing voltmeter testing, should I have the engine running or not? I'm lost.

Thanx for the replies received so far.
Dano

P.S. When trying to fix electrical problems, is it normal to have feelings of wanting to yank out the wiring harness and do a tribal yell at the top of my lungs.


69 C10 LWB 250 L-6/3spd
79 C30 Crew Cab Dually 454 V-8/TH-400

"Takes more than a coat of paint to make it at Thunder Road!"
Re: Battery Not holding a charge 2 #90928 Fri Nov 12 2004 11:39 PM
Joined: Jul 2003
Posts: 87
F
Fahr Offline
Member
yes grin

Re: Battery Not holding a charge 2 #90929 Fri Nov 12 2004 11:58 PM
Joined: Sep 2004
Posts: 235
B
Big T Offline
Shop Shark
Patience, We will get this figuered out. When you turn the key to the on position(not running) the volt gauge should read around 12 volts. When the engine is runing, the volt gauge should read 13 to 14 volts.that means it is charging. If the volts on the gauge is 12 volts or less, it's not charging. Ask the parts store where you bought it if the are able to bench test the alternater for you. It might be just a bad alternater right out of the box.

Re: Battery Not holding a charge 2 #90930 Sat Nov 13 2004 12:16 AM
Joined: Sep 2004
Posts: 235
B
Big T Offline
Shop Shark
The other thing you might want to check is make sure the big wire on the alternater has power. does not matter if the key is on or off. If it does not have power, follow the wire back and you should find the problem. By looking at the wireing diagram, it shows it going to a fuse link. They are the small wires that are conected to the main battery wire on the starter. Make sure they are all conected. If you find one burnt in half, that is your problem. To fix it right, you need to get fuse link wire. Fuse link saves your truck from a major melt down.

Re: Battery Not holding a charge 2 #90931 Sat Nov 13 2004 10:49 PM
Joined: Jun 2004
Posts: 8,094
W
Wrenchbender Ret. Offline
Master Gabster
Follow bigt,s test & than check the 2 small
wires. One should be hot all the time. The
other comes on with the ign. switch through
a resistor wire (test light dim). smile


They say money can't buy happiness. It can buy old Chevy trucks though. Same thing.

1956 Chevy 1/2-Ton Pickup

Re: Battery Not holding a charge 2 #90932 Thu Nov 25 2004 10:18 PM
Joined: Mar 2004
Posts: 58
D
dano69c10 Offline OP
Member
After weeks of frustration;
found out the "brand new" alternator was maybe bad "out of the box".
I also found a bad section of wire in the harness.
I don't know if the bad wire ruined the alt or not.
Ran voltage tests and everything is OK fine!

Thanx to everyone and their advice.
Dano


69 C10 LWB 250 L-6/3spd
79 C30 Crew Cab Dually 454 V-8/TH-400

"Takes more than a coat of paint to make it at Thunder Road!"

Moderated by  Rusty Rod 

Home | FAQ | Forum | Swap Meet | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
Powered by UBB.threads™ PHP Forum Software 7.7.3