The Stovebolt.com Forums Home | FAQ | Gallery | Tech Tips | Events | Features | Search
What's going on?
What's happening?

Find out in
THE SHOPS !

Genearl Truck Talk
20,267 threads; 177,521 posts
The Engine Shop
32,460 threads; 255,065 post
Driveline
8,796 threads; 65,970 posts
The Electrical Bay
9,505 threads; 74,285 posts
Sub: The Radio Bench
The HiPo Shop
5,040 threads; 46,029 posts
Paint & Body Shop
12,505 threads; 81,120 posts
Sub: The Doors
Interiors
4,059 threads; 26,817 posts
The Tool Chest
1,762 threads; 26,817 posts
Making a Stovebolt Bed
1,052 threads; 6,659 posts
Searching the Site

Get info about how to search the entire Stovebolt site here. To do a search for just the forums, get those details in the IT Shortbus fourm.
Old Truck Calendars
Months of truck photos!
Nothing like an old truck calendar

Stovebolt Calendars

Check for details!


Who's Online Now
13 members (DannyW, Frank50, Cosmo, Bill Trotter, bolter5410, 1 invisible), 126 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums59
Topics128,597
Posts1,041,772
Members46,055
Most Online1,229
Jan 21st, 2020
Step-by-step instructions for pictures in the forums
Previous Thread
Next Thread
Print Thread
#594297 Sat Nov 21 2009 01:40 PM
Joined: Mar 2006
Posts: 263
P
Shop Shark
Decided to take the '49 out yesterday for one last spin. I installed a regulator valve for the fresh air heater a while back and noticed yesterday that the heater never really blew out warm air. Just cool air no matter where I turned the knob on the valve. Did I do something wrong on the install? Hoping someone might have an idea. Thanks


My truck: She may not be the prettiest girl at the dance, but she's all mine!
pablos49 #594303 Sat Nov 21 2009 02:23 PM
Joined: Jan 2009
Posts: 1,693
P
Shop Shark
Could it be air locked? somtimes there is some air in the heater and the coolent will not push it out because the air compesses and the coolent will not move , the best way to get the last of the air out is to loosen the return line the lower one coming from the heater a little and let the engine run the air pocket sould come right out and the hoses should start getting hot .


Pete

Pete52 #594311 Sat Nov 21 2009 03:25 PM
Joined: Mar 2006
Posts: 263
P
Shop Shark
Thanks, Pete. I'm going to give that a try in a little bit.


My truck: She may not be the prettiest girl at the dance, but she's all mine!
pablos49 #594382 Sat Nov 21 2009 08:42 PM
Joined: Feb 2008
Posts: 14
M
Wrench Fetcher
I am thinking you do not have the heater hoses hooked up properly.
Here is the factory diagram that shows the correct routing of the hoses.

http://members.cox.net/images4755/freshairheaterhosehookup.jpg





Joined: Mar 2006
Posts: 263
P
Shop Shark
I tried Pete's idea. Between that and adding about a quart of anti-freeze I now have heat. Thanks for the help.


My truck: She may not be the prettiest girl at the dance, but she's all mine!

Moderated by  ndkid275, Phak1 

Link Copied to Clipboard
Home | FAQ | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
Powered by UBB.threads™ PHP Forum Software 7.7.5