The Stovebolt.com Forums Home | FAQ | Gallery | Tech Tips | Events | Features | Search
Getting back to business
First round of holidays is about over. A few weeks before the next ones. For some of us...

Winter is Coming
Time to think about wintering your Bolt.
(continued)

A good Tech Tip
WINTERIZING YOUR TRUCK
including a link back to the Forums for some new thoughts.

Searching the Site

Get info about how to search the entire Stovebolt site here. To do a search for just the forums, get those details in the IT Shortbus fourm.
Old Truck Calendars
In the works
Nothing like an old truck calendar

2023 Stovebolt Calendars

Check for details!


Who's Online Now
3 members (Jethro in Va, Luray, Brando4905), 85 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums60
Topics127,746
Posts1,047,335
Members46,412
Most Online1,229
Jan 21st, 2020
Step-by-step instructions for pictures in the forums
Previous Thread
Next Thread
Print Thread
#1450028 Sat Apr 30 2022 06:29 PM
Joined: Jul 2014
Posts: 9
D
'Bolter
I have an original 1948 3100 truck. The radio light comes on but no noise at all from speakers. Any pointers on getting it to work or know of anyone in western South Dakota to take a look?
Thanks !!

Attached Images
IMG_0985.jpg (39.61 KB, 100 downloads)
Joined: Dec 2002
Posts: 4,432
Moderator - The Electrical Bay and Rocky Mountain Bolters
My guess would be that something is burned out inside? At any rate, i'll move your question to the radio forum where the radio experts reside.


Another quality post.


Real Trucks Rattle

HELP! The Paranoids are after me!
Joined: May 2015
Posts: 6,304
Housekeeping (Moderator) Making a Stovebolt Bed & Paint and Body Shop Forums
Here is a link to some possible help for you.


Kevin
Newest Project - 51 Chevy 3100 work truck. Photos [flickr.com]
#2 - '29 Ford pickup restored from the ground up.
First car '29 Ford Special Coupe
Busting rust since the mid-60's
Joined: Mar 2010
Posts: 1,667
B
Curmudgeon
The radio is 74 years old. Components inside simply age out.

To give a little more insight on what typically happens:

The circuit that creates the higher voltage for the vacuum tubes has a oscillating mechanical device "vibrator" with contacts that usually corrode and stick over time.
There are several capacitors that most likely have aged and failed or changed value. Most are simply replaced with modern ones.
Rust, dirt, dust, spider webs, you name it. The radio will need a good cleaning inside.
The speaker cone and voice coil probably have dried out and cracked and need repair.
The tuner string usually ages and breaks. You notice this when you turn the knob but the needle doesn't move.
Even after doing the above you may hear pops and cracks while tuning like July 4th fireworks (microphonics) which can be caused by dirty, bad or corroded tuner bearings.
The list goes on....

This is why you want an experienced radio serviceman and not a computer tech to work on your radio.
Labor is a lot of the repair cost.


"Adding CFM to a truck will only help at engine speeds you don't want to use."
"I found there was nothing to gain beyond 400 CFM."
Joined: Mar 2002
Posts: 9,171
'Bolter
The most common failure in these old radios is the vibrator. However there are capacitors which should be replaced, namely all the wax covered paper ones and the electrolytics in the silver can. I don't think this radio would ever have static from dirty bearings because the tuning mechanism is not a variable capacitor but an array of moving ferrite cores inside coils. The best approach is to replace all the above parts before trying to troubleshoot the radio. I have repaired numerous radios where the old tubes test in the good region and perform correctly.

Joined: Jul 2014
Posts: 9
D
'Bolter
Thank you for the pointers !!

Joined: Aug 2018
Posts: 534
M
'Bolter
You have been given some good advice from some of these guys. In another life, I worked on stuff like these old radios. Since you said the light is on, your fuse is almost sure to be OK. Still would be silly not to check it. Of course, I would test all of the tubes before going any further, simply because it's quick and easy. It's hard to find a tube tester these days, but most communities have some old guy who works on old electronics for a hobby. He'll have one. If a tube checker says a tube is good, then it probably is. If a tester says it's bad, then it MIGHT be bad. Beyond that truckernix and bouymaker gave you good advice and I would follow it. If it were me, while I had the radio apart, I would change all of the old paper capacitors, and the electrolytics capacitors too. If they're not bad right now, they will be in the near future. Oh I forgot to mention, if your vibrator is working, you should be able to hear a faint humm from it, unless it's been replaced with a solid state vibrator. I would replace the vibrator while it's apart too.


Mike Burns
1940 Chev 1/2 ton
1953 Chev 1/2 ton
1953 Ford Victoria
1950 Studebaker Starlight Coupe
Joined: Mar 2002
Posts: 9,171
'Bolter
From the shot of your dash, the radio buttons and knobs look like they are in good shape. I am thinking maybe they are new and that the radio has had work done. You could take a photo of the inside and post it. That might tell us more. A bad vibrator will not allow the radio to work so maybe that may be your only problem.


Moderated by  truckernix 

Link Copied to Clipboard
Home | FAQ | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
Powered by UBB.threads™ PHP Forum Software 7.7.5