The Stovebolt.com Forums Home | FAQ | Forum | Swap Meet | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
More great reading ...


Check this out!

Refueling the Past

Our very own
Archie
“46 Texaco”
Bentz

has a #1 ranked (on Amazon) book on Automotive History!

See link below for image.

REFUELING
THE
PAST



Find all the details here.

Stovebolt Site Search
 
Old Truck Calendars
Months of truck photos!
Nothing like an old truck calendar

Stovebolt Calendars

Check for details!


Who's Online Now
6 members (Bowtie john, modiol, Hotrod Lincoln, jasrking, DennisM, Johnny N), 239 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums60
Topics123,437
Posts996,200
Members44,665
Most Online1,229
Jan 21st, 2020
Image Posting Policy
Previous Thread
Next Thread
Print Thread
62 C10 235 Vacuum advance
#1413460 Thu Jun 10 2021 08:13 PM
Joined: Aug 2012
Posts: 5
6
'Bolter
I believe my vacuum advance is sticking/no good on my 235. I have never replaced one of these before. Any tips/directions would be greatly appreciated.

Re: 62 C10 235 Vacuum advance
66fairlane #1413489 Fri Jun 11 2021 01:27 AM
Joined: Mar 2019
Posts: 1,254
G
'Bolter
I would make sure thats its not working 1st. Does the distributor turn by hand easily and return with out the motor running? Did you apply vacumm to the advance to verify operation? When you rev up the motor in neutral, does the distributor move and or return at all. Just a couple quick checks b4 pulling the distributor to change it.


Moderated by  Hambone 

Link Copied to Clipboard
Home | FAQ | Forum | Swap Meet | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
Powered by UBB.threads™ PHP Forum Software 7.7.4