The Stovebolt Page Forums Home | FAQ | Forum | Swap Meet | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
Helping out ...


EVENTS

Check in for status!

Jump over to the Events Forum, to post events -- new ones or the ones we have been enjoying for some time.
Look to see what's been cancelled or postponed.

Encourage one another!

Stovebolt Site Search
 
Old Truck Calendars
Months of truck photos!
Nothing like an old truck calendar

Stovebolt Calendars

Check for details!


Who's Online Now
11 members (5 Window 9434, Paul_WNC, dirtball, Jon G, Justhorsenround, 1 invisible), 113 guests, and 3 robots.
Key: Admin, Global Mod, Mod
Forum Statistics
Forums50
Topics119,455
Posts956,423
Members43,405
Most Online1,229
Jan 21st, 2020
Image Posting Policy
Previous Thread
Next Thread
Print Thread
37 running boards..first ?
#1328579 Thu Oct 03 2019 12:21 AM
Joined: Jan 2018
Posts: 333
B
Shop Shark
Finally got my radiator and grille and shroud installed.Going to mount front fenders next but seen on a old forum question that running boards should be on first? Also doesn't the box go on last as the front mounting bolts go through the splash apron. Any help would be great!! Thanks Bill

Re: 37 running boards..first ?
Bill Trotter #1328625 Thu Oct 03 2019 01:56 PM
Joined: Feb 2008
Posts: 1,044
4
Shop Shark
Bill
In the reassemble of my ‘46, many similarities between that model and a ‘37, this was the sequence used. I installed the pre-assembled bed, then the running boards followed by the fenders. The fenders needed to bolt to the running boards and trying to wrestle the boards on after mounting the fenders would certainly have been a disaster for the adjacent painted surfaces. I used painters tape to protect matching surfaces, then removed it when done.

Re: 37 running boards..first ?
Bill Trotter #1328651 Thu Oct 03 2019 04:24 PM
Joined: Jan 2018
Posts: 333
B
Shop Shark
Did you install the splash aprons with the box and then attach the running boards? Thanks for your help

Re: 37 running boards..first ?
Bill Trotter #1328652 Thu Oct 03 2019 04:48 PM
Joined: Feb 2008
Posts: 1,044
4
Shop Shark
Aprons were bolted on the boards. Don’t know about this step for a ‘37, but the ‘46 aprons on my truck didn’t mount on the bed. The aprons had two(?) holes on top that fit over rivets on the frame.

Re: 37 running boards..first ?
Bill Trotter #1328701 Fri Oct 04 2019 01:00 AM
Joined: Jan 2018
Posts: 333
B
Shop Shark
Yes my aprons are also bolted to the running boards. My front bed bolts also go through the aprons and the new apron's only have the rivet holes punched out so I will have to figure where that hole goes after box is on. Thanks for you help, will find out as I continue on the assembly. Bill


Moderated by  HandyAndy, klhansen 

Link Copied to Clipboard
Home | FAQ | Forum | Swap Meet | Gallery | Tech Tips | Events | Features | Search | Hoo-Ya Shop
Powered by UBB.threads™ PHP Forum Software 7.7.4